Keyboard shortcuts

Press ← or → to navigate between chapters

Press S or / to search in the book

Press ? to show this help

Press Esc to hide this help

Huvudmeny

Översikt

I detta avsnitt kommer vi att inspektera alla menyer och lära oss vad de olika menyalternativen är till för. Du kan aktivera menyerna genom att välja dem med musen, men du kan också aktivera menyerna genom att trycka på Alt-tangenten på tangentbordet.

När Alt-tangenten är nedtryckt, dyker menygenvägar upp (understrukna bokstäver i menyerna). Om du till exempel trycker Alt+A så öppnas Arkiv-menyn.

Du kan också flytta mellan menyer och menyalternativ med piltangenterna. Tryck på Enter (Retur) för att välja ett menyalternativ som är markerat.

Ethiriskomponenter

I Ethiris Admin hanteras olika Ethiriskomponenter. Dessa är Ethiris Server, Ethiris Client och Ethiris Admin-projekt.

Ethiris Server och Ethiris Client är riktiga exekverbara program medan Ethiris Admin-projekt bara är en konfigurationsfil med syfte att hålla ordning på de andra komponenterna i ett projekt.

Online vs offline

Vid det här laget är det lämpligt att nämna skillnaden mellan online och offline.

Online-konfigurering innebär att Ethiris Admin kopplar upp sig mot Ethiriskomponenten online och frågar efter aktuell konfiguration. Efter konfigurationsförändringar har gjorts i Ethiris Admin och konfigurationen sparas, kommer konfigurationen att skickas tillbaka till Ethiriskomponenten och förändringarna träder i kraft omedelbart.

Offline-konfigurering å andra sidan arbetar mot en konfigurationsfil som ligger lagrad på disk någonstans. Ethiriskomponenten i fråga behöver inte ens vara installerad. Förändringar i konfigurationen kommer att sparas direkt i konfigurationsfilen. För att konfigurationsförändringarna ska få effekt måste Ethiriskomponenten startas och komponenten måste ladda in den nya konfigurationsfilen.

För tillfället är det inte alla Ethiriskomponenter som stöder online-konfigurering. Det är inte heller alla Ethiriskomponenter som stöder offline-konfigurering.

Online-konfigurering stöds av Ethiris Server.

Offline-konfigurering stöds av Ethiris Client.

Det finns också ett koncept som kallas för Ethiris Admin-projekt som är en offline-komponent (en konfigurationsfil helt enkelt).Tangentbordsgenvägar

Ett antal tangentbordsgenvägar kan komma till användning. För att komma åt tangentbordsgenvägarna, tryck ned Alt-tangenten. När Alt är nedtryckt dyker de tillgängliga tangentbordsgenvägarna upp som understrukna bokstäver i menyer och knappar.

Som standard är det bara menyalternativ i huvudmenyn som har tangentbordsgenvägar. Dessa är:

Alt-A – Arkiv-menyn.

Alt-A – Avsluta-menyn i Arkiv-menyn.

Alt-V – Vy-menyn.

Alt-V – Verktyg-menyn.

Alt-H – Hjälp-menyn.

Alt-C – Kollapsa alla block i Skriptet.

Alt-Shift-C – Expandera alla block i Skriptet.

Arkiv-menyn

Arkiv-menyn i Ethiris Admin.

Arkiv->Ny Ethiris-komponent används för att skapa en ny konfiguration för en Ethiriskomponent. Detta används vanligtvis för att skapa en ny Ethiris Client-konfiguration från allra första början.

Menyn Ny Ethiris-komponent i Ethiris Admin.

Som diskuterades ovan, är endast Ethiris Admin-projekt och Ethiris Client tillgängliga för offline-konfigurering. En ny klientkonfiguration skapas på den valda servern, se Figur 2.49.

En ny klientkonfiguration har skapats

Dubbelklick på Klientkonfigurationer i trädvyn öppnar tillhörande panel.

Panelen Klientkonfigurationer

Det finns möjlighet att sätta behörighet, vilket innebär att man utan den behörigheten inte ser att de konfigurationerna existerar.

Klientkonfigurationerna hanteras av en konfigurationsserver, en Ethiris Server. För att öppna klientkonfigurationen i Admin, dubbelklicka på den i trädvyn. Konfigurationen öppnas då i Admin, se Figur 2.51.

Om du vill ändra namnet på klientkonfigurationen kan du antingen ändra det i panelen Klientkonfigurationer eller direkt under klientkonfigurationen i Admin.

En ny Ethiris Client-komponent är skapad.

Om du väljer Ethiris Client med hjälp av guide… kommer konfigurationsguiden att starta i steg 4, d v s man kan inte i detta läge lägga till ytterligare en Ethiris Server via guiden utan man kan endast skapa nya klientkonfigurationer.

Klientkonfigurationen som skapas av guiden kommer att ansluta till samtliga de Ethiris Serverar som finns i trädvyn i Ethiris Admin. Det kan alltså vara fler än en.

Skulle du välja att skapa ett nytt Ethiris Admin-projekt kommer aktuellt projekt att stängas och ett nytt projekt skapas innehållande aktuella Ethiriskomponenter i trädvyn. I exemplet i Figur 2.52 har vi skapat ett helt nytt projekt (med befintliga Ethiriskomponenter) och gett det namnet My new project.

Ett nytt projekt är skapat.

Arkiv->Anslut Ethiris-komponent används för uppkoppling online till en Ethiriskomponent. För tillfället är en online uppkoppling endast tillgänglig för Ethiris Server.

Menyn Anslut Ethiris-komponent i Ethiris Admin.

En dialog Anslut komponent öppnas, se Figur 2.54 .

Dialogen Anslut Ethiriskomponent i Ethiris Admin.

Alla Ethiris Servrar som Ethiris Admin kan hitta är listade, klicka på den som du skulle vilja ansluta till och sedan på Anslut. Om servern du letar efter inte dyker upp så går det att trycka på Manuell Anslutning.

Notera att Ethiris Admin inte söker efter servrar när dialogen öppnas. Om servern du letar efter startades efter att Admin startade så kan det vara en idé att Söka igen.

Dialogen Anslut Ethiriskomponent satt till Manuell Anslutning.

Adress är IP-adressen för datorn där Ethiris Server kör. 127.0.0.1 är ett alias för den lokala datorn. Du kan också mata in ett datornamn, till exempel Galatea så länge det finns en DNS (Domain Name Server) i nätverket som kan lösa upp namnet.

Port är den port som Ethiris Server lyssnar på för inkommande begäran om anslutning. Denna är som standard 1235 och behöver sällan ändras.

Anslut med hjälp av Ethiris Access Service om denna ruta kryssas i, så byts Adress och Port ut med ett fält för Ethiris Access Service-namn. Detta kräver en aktiv tjänst för att fungera, ange då det EAS-namn som tillhör den servern som anslutning skall göras mot. Notera att detta är tänkt att nyttjas externt och inte lokalt i samma nätverk som servern.

Klicka på Anslut för att ansluta online till Ethiris Server.

Efter anslutning, läggs Ethiris Server komponenten till i Ethirisutforskarens trädvy.

Arkiv->Öppna Ethiris-komponent används för att öppna en existerande konfigurationsfil för en Ethiriskomponent offline. För tillfället är Ethiris Client och Ethiris Admin-projekt tillgängliga.

Menyn Öppna Ethiris-komponent i Ethiris Admin.

Arkiv->Öppna Ethiris-komponent->Ethiris Client… används för att importera en gammal klientkonfiguration som är sparad i en fil till den server som är markerad i trädvyn innan detta menyalternativ valdes.

En dialog Öppna komponent öppnas, se Figur 2.57.

Dialogen Öppna Ethiriskomponent i Ethiris Admin.

Bläddra efter önskad fil, välj den och klicka sedan på knappen Öppna för att importera konfigurationsfilen. Tillhörande Ethiriskomponent läggs till Ethirisutforskarens trädvy under Klientkonfigurationer för den valda servern.

Arkiv->Stäng projekt används för att stänga aktuellt projekt. Resultatet blir att hela Ethirisutforskaren rensas och Ethiris Admin ser ut som första gången den startas.

Figur . Ethiris Admin efter att ha valt menyn Stäng projekt.

Arkiv->Spara sparar den för tillfället markerade komponenten i Ethirisutforskarens trädvy. I Figur 2.59 kommer Ethiris Server-komponenten Obelix att sparas eftersom en undernod till komponenten är vald i trädvyn.

Observera den lilla stjärnan i ikonen för Ethiris Server. Den indikerar att någon information har ändrats och att serverkonfigurationen behöver sparas.

Ethiris Server Obelix är den för tillfället valda Ethiriskomponenten.

Om den valda komponenten är en Ethiris Server kommer konfigurationen att skickas till online servern.

Om den valda komponenten är en Ethiris Client kommer konfigurationen i stället att skickas till den Ethiris Server som är konfigurationsserver för den aktuella klientkonfigurationen.

Arkiv>Spara alla sparar samtliga Ethiriskomponenter i Ethirisutforskaren inklusive konfigurationsfilen för Ethiris Admin-projekt. Som standard skapas ett automatiskt projekt i Ethiris Admin som håller reda på ingående Ethiriskomponenter. Detta automatiska projekt behöver inte hanteras manuellt utan sköts helt och hållet av Ethiris Admin.

Arkiv->Tidigare projekt visar en lista över upp till 10 projekt som tidigare har använts. Att välja ett projekt i listan är det samma som att öppna det via menyn Arkiv->Öppna Ethiris-komponent->Ethiris Admin-projekt… och sedan bläddra efter projektfilen manuellt.

Detta är en mycket bekvämare metod att öppna projekt du tidigare har arbetat med.

Menyn Tidigare projekt.

Arkiv->Tidigare komponenter är liknande som menyalternativet Tidigare projekt. Här listas de senaste konfigurationer för Ethiris Server, Ethiris Cluster och Ethiris Client som du har arbetat med.

Menyn Tidigare komponenter.

Om du väljer en Ethiris Server-komponent är detta det samma som att välja menyalternativet Arkiv->Anslut Ethiris-komponent->Ethiris Server… och sedan välja motsvarande online server.

Om du väljer en Ethiris Client-komponent är detta det samma som att dubbelklicka på den klientkonfigurationen på servern. I exemplet ovan innebär Asterix|Obelix att klientkonfigurationen Asterix som hanteras av servern Obelix öppnas. Eftersom klientkonfigurationerna hanteras av en konfigurationsserver, måste denna server vara laddad i Ethiris Admin för att en klientkonfiguration skall kunna öppnas. Är den inte redan det, får man en fråga om man vill ansluta till servern.

När du väljer en komponent från den här listan kommer komponenten att läggas till aktuellt projekt, d v s komponenten dyker upp i Ethirisutforskaren tillsammans med övriga komponenter.

Arkiv->Avsluta stänger Ethiris Admin. Om det finns några ändringar i konfigurationen som inte är sparade visas en dialog där du kan välja att fortsätta stänga applikationen eller ångra dig (klicka Nej) och få en chans att spara ändringarna.

Dialog som meddelar att det finns osparade ändringar.

Visamenyn

Visa menyn i Ethiris Admin.

Visa menyn är helt och hållet till för att öppna olika fönster. Om det valda fönstret redan är öppet, får det fokus och om det ingår i en flikgrupp, väljs motsvarande flik och fönstret blir därmed synligt.

Ethirisutforskaren öppnar verktygsfönstret Ethirisutforskaren.

Verktygsmenyn

Verktygsmenyn i Ethiris Admin.

Startlösenord… öppnar en dialog där du kan mata in ett lösenord som krävs för att starta Ethiris Admin.

Dialogen för Startlösenord.

Bocka för kryssrutan Kräv startlösenord och mata in ett Lösenord om du vill skydda Ethiris Admin från otillåten användning.

När du startar Ethiris Admin nästa gång visas dialogen Skriv in lösenord som i Figur 2.66.

Dialog för att mata in startlösenord.

Om du inte längre vill kräva ett lösenord vid start av Ethiris Admin, avmarkera kryssrutan Kräv startlösenord igen.

Välj språk visar en undermeny med tillgängliga språk.

Undermeny för att välja aktuellt språk.

Hjälpmenyn

Hjälpmenyn i Ethiris Admin.

Hjälpmenyn innehåller olika menyalternativ beroende på om du har valt att installera manualerna eller inte.

De sju första menyalternativen i exemplet ovan används för att öppna tillhörande PDF av manualen. För att det ska fungera krävs att det finns en PDF-läsare installerad på den lokala datorn, till exempel Adobe Reader.

Nästa två menyalternativ visar dialogen Om och det sista, Kentima QuickSupport öppnar en TeamViewer QuickSupport dialog.

Visa mjukvarulicenser öppnar dialogen Om med alternativet Visa mjukvarulicenser aktiverat. Här visas licensavtalet för Ethiris tillsammans med eventuella tredjepartslicenser.

Dialogen Om med Visa licenser öppen.

Om Ethiris Admin öppnar dialogen Om.

Dialogen Om.

Dialogen Om visar information om aktuellt versionsnummer för aktuell Ethirisinstallation.